Author Topic: Problem of launching OVITO 2.9.0 on Centos 6.4  (Read 117 times)

qqlovekerry

  • Newbie
  • *
  • Posts: 17
Problem of launching OVITO 2.9.0 on Centos 6.4
« on: May 05, 2019, 03:57:02 AM »
Hello everyone,
When I tried to run OVITO 2.9.0 on the HPC with Centos 6.4, it failed with some error.
When I typed
Code: [Select]
./bin/ovito in the terminal, the following message appeared in the terminal.
Code: [Select]
./bin/ovito: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libGui.so)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libGui.so)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.18' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libGui.so)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libOpenGLRenderer.so)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.14' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libCore.so)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.15' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libCore.so)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libCore.so)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libCore.so)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libQt5Concurrent.so.5)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libQt5Widgets.so.5)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libQt5Gui.so.5)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libQt5Network.so.5)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.9' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libQt5Core.so.5)
./bin/ovito: /usr/lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /home/liuwenqiang/apps/ovito-2.9.0-x86_64/bin/../lib/ovito/libQt5Core.so.5
Could you please give me some advice on how to fix this problem?
Any help would be much appreciated!

Constanze Kalcher

  • Administrator
  • Sr. Member
  • *****
  • Posts: 290
Re: Problem of launching OVITO 2.9.0 on Centos 6.4
« Reply #1 on: May 06, 2019, 11:48:40 AM »
Hello,

please follow the instructions on the Download page under Note to users of RHEL and similar Linux distributions
http://www.ovito.org/index.php/download,
i.e. download and copy the two *.so files to the lib/ovito/ subdirectory of the OVITO installation. This should fix your error.

However, are you sure that your HPC supports remote 3D visualization? If that's not the case you should use
ovitos (which is OVITO's python scripting interface) instead of the graphical user interface.
See
http://www.ovito.org/manual/python/,
for more details.

-Constanze

qqlovekerry

  • Newbie
  • *
  • Posts: 17
Re: Problem of launching OVITO 2.9.0 on Centos 6.4
« Reply #2 on: May 06, 2019, 01:45:28 PM »
Hello, thanks very much for your help!
I am sorry I did not mention that part of instructions before. It works fine now.
I am using VNC to access the GUI of the HPC, thus sometimes I do not need to download the generated files.
Again, thanks very much! That helps a lot.

Best Regards,
Wenqiang