Author Topic: Problem in loading file in OVITO 3.0.0-dev334 on macOS  (Read 221 times)

Mahsa

  • Newbie
  • *
  • Posts: 9
Problem in loading file in OVITO 3.0.0-dev334 on macOS
« on: January 31, 2019, 12:56:50 AM »
Hi,

I had OVITO 2.9.0 on my laptop (macOS High Sierra version 10.13.4). However, I had some problems in running modifiers and today I installed the 3.0.0-dev334 version. In this new version when I load a file (like a pdb file) the window is just white and doesn't show anything! Some icons are also deactive but it is strange since when I click on the camera button it shows the picture of the molecules. Could you please help me with this issue?

Best regards,
Mahsa

Alexander Stukowski

  • Administrator
  • Hero Member
  • *****
  • Posts: 588
Re: Problem in loading file in OVITO 3.0.0-dev334 on macOS
« Reply #1 on: January 31, 2019, 08:14:40 AM »
Dear Mahsa,

Please post a screenshot of the Ovito window here. I haven't seen this happening before and would like to get an idea of how it looks on your computer.

Please then try an older development build, for example this one:

http://ovito.org/download/testing/ovito-3.0.0-dev234-macos.dmg

Does it show the same problem?

-Alex

Mahsa

  • Newbie
  • *
  • Posts: 9
Re: Problem in loading file in OVITO 3.0.0-dev334 on macOS
« Reply #2 on: January 31, 2019, 10:21:28 AM »
Dear Alex,

Thank you for your reply! Please see attached to this post the screenshots of the OVITO window for the 3.0.0-dev334 version.

Besides, I installed 3.0.0-dev234-macos version and it works without any problem.

Best regards,
Mahsa

Alexander Stukowski

  • Administrator
  • Hero Member
  • *****
  • Posts: 588
Re: Problem in loading file in OVITO 3.0.0-dev334 on macOS
« Reply #3 on: January 31, 2019, 04:04:09 PM »
Thanks.

The main difference between builds dev234 and dev334 is the version of the included Qt library, which is used by Ovito for its user interface and also the 3d viewports. The latter Ovito build comes with Qt 5.12.0, which could be the reason for the reported problem, but I am not sure. Sometimes, things that used to work become broken in new Qt versions.
The Qt people have just published the Qt 5.12.1 maintenance release. My hope is that it includes a fix for the problem. I uploaded Ovito build dev340 to the www.ovito.org website today. Please give it a try.

-Alex

Mahsa

  • Newbie
  • *
  • Posts: 9
Re: Problem in loading file in OVITO 3.0.0-dev334 on macOS
« Reply #4 on: January 31, 2019, 04:15:03 PM »
Thank you for the explanation.

I tried this newer version but the same problem exists in this version as well. Therefore, I continue using 3.0.0-dev234-macos version.

Best regards,
Mahsa

Alexander Stukowski

  • Administrator
  • Hero Member
  • *****
  • Posts: 588
Re: Problem in loading file in OVITO 3.0.0-dev334 on macOS
« Reply #5 on: January 31, 2019, 04:24:53 PM »
Thanks for letting me know.
One more thing I would like you to do: In the non-working Ovito version, please go to the Help menu, select "OpenGL Information" and send me the displayed system information. Thanks.

Mahsa

  • Newbie
  • *
  • Posts: 9
Re: Problem in loading file in OVITO 3.0.0-dev334 on macOS
« Reply #6 on: January 31, 2019, 04:37:24 PM »
You can see the information below:

======= System info =======
Date: Thu Jan 31 16:35:35 2019
Application: Ovito 3.0.0-dev340
OS: Mac OS X (15)
Architecture: 64 bit
Floating-point size: 64 bit
Qt version: 5.12.1
Command line: /Applications/Ovito.app/Contents/MacOS/ovito
======= OpenGL info =======
Version: 4.1
Profile: core
Alpha: 0
Vendor: Intel Inc.
Renderer: Intel Iris Pro OpenGL Engine
Version string: 4.1 INTEL-10.32.48
Swap behavior: double buffer
Depth buffer size: 24
Stencil buffer size: 8
Shading language: 4.10
Geometry shaders supported: yes
Using deprecated functions: no
Using point sprites: yes
Using geometry shaders: yes
Context sharing enabled: no


Best regards,
Mahsa

Alexander Stukowski

  • Administrator
  • Hero Member
  • *****
  • Posts: 588
Re: Problem in loading file in OVITO 3.0.0-dev334 on macOS
« Reply #7 on: February 01, 2019, 09:38:54 AM »
Let's try it one more time (if you don't mind). This the current Ovito version built against the old Qt library version (5.9.7):

http://ovito.org/download/testing/ovito-3.0.0-dev341-macos.dmg

Let's see if it works any better than the previous build on your machine.

Mahsa

  • Newbie
  • *
  • Posts: 9
Re: Problem in loading file in OVITO 3.0.0-dev334 on macOS
« Reply #8 on: February 01, 2019, 09:50:24 AM »
This version works well! Thank you.

Best regards,
Mahsa