Author Topic: Not able to visualize .CFG file in "OVITO" but the same file works with "Atomeye  (Read 135 times)

sairajdream

  • Newbie
  • *
  • Posts: 3
Hi OVITO users,

I just stated OVITO, so I don't have any idea about this.
I have created my first input "copper.cfg" file from this tutorial(Atomsk tutorial  http://atomsk.univ-lille1.fr/tutorial_unitcells.php
The same file I am able to see using "Atomeye" but can't see using OVITO getting this error

Parsing error in line 15 of CFG file.
Data line in input file does not contain enough columns. Expected 3 file columns, but found only 1.

you can see the error prompt in this link (https://yadi.sk/i/Nw4yFYjo6cpHeA
) sorry I don't know how to insert an image using "[img http:// img]


This is my Copper.cfg file

Number of particles = 4
# Fcc Cu oriented X=[100], Y=[010], Z=[001].
A = 1.000000000 Angstrom (basic length-scale)
H0(1,1) =       3.59700000
H0(1,2) =       0.00000000
H0(1,3) =       0.00000000
H0(2,1) =       0.00000000
H0(2,2) =       3.59700000
H0(2,3) =       0.00000000
H0(3,1) =       0.00000000
H0(3,2) =       0.00000000
H0(3,3) =       3.59700000
.NO_VELOCITY.
entry_count = 3
  63.5460
Cu
0.00000000    0.00000000    0.00000000
0.50000000    0.50000000    0.00000000
0.00000000    0.50000000    0.50000000
0.50000000    0.00000000    0.50000000



Alexander Stukowski

  • Administrator
  • Sr. Member
  • *****
  • Posts: 475
Hi,
I loaded your file in OVITO 2.9.0 and OVITO 3.0.0-dev, without any problems. Which version of the program are you using?

-Alex

sairajdream

  • Newbie
  • *
  • Posts: 3
Thanks, Alex for replying

I tried this file with  OVITO 2.9.0, OVITO 3.0.0-dev, and OVITO 2.3.3+dfsg1-2build1(I found it on ubuntu software center) too
but every one showing the same error.

Constanze Kalcher

  • Administrator
  • Jr. Member
  • *****
  • Posts: 81
Hi sairajdream,

I also tried and could open your file without any problem. Could you please upload your file here instead of just copying the text, because the latter one seems to be perfectly fine.

-Constanze

sairajdream

  • Newbie
  • *
  • Posts: 3
Dear  Constanze and Alexander,
(sorry for the late reply, I was super busy today)

My Problem is now solved. OVITO 3.0.0 is now showing the visuals without any problem.
I don't know what was the exact problem, but It is better to summarize what I did so that you can help others.

Phase 1: Installation


First I downloaded OVITO 3.0 in my Ubuntu Mate 16.04

then for installation, I tried to extract it using below command.
“ tar xzf ovito-3.0.0-x86_64.tar.gz”

but it doesn’t work it shows this error

sai@sai:~$ tar xzf ovito-3.0.0-dev234-x86_64
tar (child): ovito-3.0.0-dev234-x86_64: Cannot read: Is a directory
tar (child): At beginning of tape, quitting now
tar (child): Error is not recoverable: exiting now

gzip: stdin: unexpected end of file
tar: Child returned status 2
tar: Error is not recoverable: exiting now
sai@sai:~$


then I  search for this problem on google and got the solution

“ tar xvf ovito-3.0.0-x86_64.tar.gz”

and I successfully installed the OVITO-3.0.0 in my system
(I did my installation in my /usr/local/bin directory to access it from anywhere )


Phase 2: Viewing  .CFG log in

After logout and login my Ubuntu I found OVITO Icon in my Menu bar, I just clicked and opened OVITO and loaded the test.cfg file then it shows that error which I asked you already. (but when Installed it after a while (there is no icon at menu bar)


Then I tried different packages one by one but non of them resolved my problem.
Then after some time I went again to OVITO installation manual and read

Extract the downloaded .tar.gz archive using the tar command, e.g.: tar xzf ovito-2.9.0-x86_64.tar.gz. This will create a new subdirectory containing the program package. Change into the new directory and start OVITO by running the executable ./bin/ovito. (and It works I don’t know why) even this thing I tried befor, I always start ovito by typing “ ovito" in the command line and then I load my file and it shows that error

any way now its working but again when I tried the Ovito 2.3 from (ubuntu software center It is showing the same error)

Suggestions from me:


1. Please change the extraction command in your manual to (It will really help to those who are a newbie in Linux)

“ tar xvf ovito-3.0.0-x86_64.tar.gz"

(but if your command is correct for other system and not working only for Ubuntu Mate 16.04 then please add this command too in your manual. Please make sure user did not face many problems, because sometimes peoples already have many problems to solve  ;D ;D ;D)

2. If you can then please check why Ubuntu software center OVITO 2.3 is giving that error.


Thanks to both of you
-Sai




Alexander Stukowski

  • Administrator
  • Sr. Member
  • *****
  • Posts: 475
Hi,

The problem you encountered in "Phase 1" is due to a typo. You ran the command "tar xzf ovito-3.0.0-dev234-x86_64" to extract the archive file, but forgot the ".tar.gz" file extension. Obviously, there already was an existing subdirectory named "ovito-3.0.0-dev234-x86_64", that's why you got that weird error message.

Running "tar xzf ovito-3.0.0-x86_64.tar.gz" should work. You wrote that you used the flags "xvf" instead. But under Ubuntu Linux, the "z" (uncompress) is option for tar.gz archives, and the "v" flag (verbose mode) doesn't affect the behavior. So "xzf" and "xvf" should lead to the same result.

The Ubuntu package repositories contain an outdated program version of OVITO (v2.3.3), which doesn't fully support the CFG file format. That's the version you had installed initially and it's the one that is invoked when you simply run "ovito" in a terminal or if you use the program menu to start up OVITO. Please uninstall this outdated version, e.g. by running "sudo apt-get remove ovito" or using the Ubuntu software center. 

The latest OVITO versions are only available as archive files that need to be manually downloaded from www.ovito.org and extracted. It looks like you accomplished this already, aside from the little problem during the extraction step.

-Alex