Author Topic: How can I scale the size of particle?  (Read 581 times)

fabregas04

  • Newbie
  • *
  • Posts: 4
How can I scale the size of particle?
« on: December 07, 2017, 02:58:41 AM »
I have several particle types in my dump file.
And they have different sizes but one of them is too large so that the others look like very tiny dust.
How can I change the other particles' size ??
If that is related to python script, I am really really a newbie to that so please tell me very specifically..

Alexander Stukowski

  • Administrator
  • Sr. Member
  • *****
  • Posts: 475
Re: How can I scale the size of particle?
« Reply #1 on: December 07, 2017, 07:13:35 AM »
Hi,

OVITO uses the following information to determine the display size for individual particles:
  • per-particle radius (the Radius particle property if present)
  • per-type radius (0 by default; but may be non-zero if the particle type is named after a chemical element; go to the "Particle Types" entry in the pipeline editor to change the per-type radii)
  • global default radius (1.0 by default; can be changed in the particle display settings panel)
I listed the settings in order of priority: If one is 0 or not defined, OVITO falls back to the next in the list when determining the effective display radius for a particle.

-Alex

fabregas04

  • Newbie
  • *
  • Posts: 4
Re: How can I scale the size of particle?
« Reply #2 on: December 07, 2017, 07:31:19 AM »
Thanks for the reply!

I think my question confuses you. I will clarify my problem more specifically.

My simulation box size is (5e3,3e3,3e3) and
Radii for particle types:
particle type 1 - 40
particle type 2 - 1.3
particle type 3 - 1.8
particle type 4 - 0.1

So in the display, particles which type is 2,3 and 4 look very small.
So I want to kind of zoom those particles without changing particle type 1.

Is it possible?

Alexander Stukowski

  • Administrator
  • Sr. Member
  • *****
  • Posts: 475
Re: How can I scale the size of particle?
« Reply #3 on: December 07, 2017, 07:51:04 AM »
Sorry, I still don't understand the problem, I think.

Why can't you just go to the "Particle Types" panel and change the radii of particle types 2-4 to some larger values to make the corresponding particles appear bigger in the viewports?

fabregas04

  • Newbie
  • *
  • Posts: 4
Re: How can I scale the size of particle?
« Reply #4 on: December 18, 2017, 01:10:24 PM »
I did what you suggested but the particle remains the same.

I set larger values to radius for particle 2-4 in the Particle types panel but nothing happened.

I use the dump files from the LAMMPS and the radius for each particles are already set in dump files.

I want to render this dump files but since particle radius is so different, it shows just empty box.

So I need to scale particle 2-4.

Is there any way except the Particle types panels?

Alexander Stukowski

  • Administrator
  • Sr. Member
  • *****
  • Posts: 475
Re: How can I scale the size of particle?
« Reply #5 on: December 18, 2017, 01:28:47 PM »
I see, so your LAMMPS dump file contains particle radius information. If this is the case, then OVITO probably maps the per-particle radius values to the internal "Radius" particle property. In this case changing the per-type radius or the default display radius has no effect, because the per-particle radii are given the highest priority (see my first post above).

That means you have two options:

  • Turn off the mapping of the radius column from the dump file to OVITO's "Radius" particle property. This can be done by selecting the "Edit column mapping" button in the file source panel.
  • Alternatively, you can overwrite the values in the "Radius" particle property. First select the particles for which you want to change the radius using the Select Particle Type modifier. Then apply the Compute Property modifier to assign a new value to the Radius property. Make sure you activate the Compute only for selected particles option here.

fabregas04

  • Newbie
  • *
  • Posts: 4
Re: How can I scale the size of particle?
« Reply #6 on: December 18, 2017, 01:58:27 PM »
Thank you very much!!

Now I can render particles without trouble.

Thanks a lot!