Author Topic: rendering problem  (Read 76 times)

oywz

  • Newbie
  • *
  • Posts: 6
rendering problem
« on: November 14, 2017, 02:25:49 AM »
I am rendering the frames but have a problem.

I render the configuration using OpenGL renderer and save to a JPG file.
Then I compare the picture between rendering image and that of viewport from Ovito.

They are so different!
It seems that a lot of particles are lost in rendering picture. 
Is there any solution for this?

Thanks in advance!

« Last Edit: November 14, 2017, 02:32:04 AM by oywz »

Alexander Stukowski

  • Administrator
  • Full Member
  • *****
  • Posts: 221
Re: rendering problem
« Reply #1 on: November 14, 2017, 09:11:02 AM »
This rendering bug is likely due to a nonconforming OpenGL graphics driver installed on your system. Please post the system report generated by OVITO when you chose "OpenGL information" from the Help menu.

You may be able to work around the graphics driver bug by changing some of the OpenGL-related settings in OVITO's application settings dialog (found under the 'General' tab).

oywz

  • Newbie
  • *
  • Posts: 6
Re: rendering problem
« Reply #2 on: November 14, 2017, 09:34:39 AM »
Below is the OpenGL information copied from Ovito:

======= System info =======
Date: 周二 十一月 14 16:31:22 2017
Application: Ovito 2.9.0
OS: Windows (144)
Architecture: 64 bit
Floating-point size: 32 bit
Qt version: 5.7.0
Command line: C:\Program Files\Ovito\ovito.exe
======= OpenGL info =======
Version: 3.2
Profile: core
Alpha: 1
Vendor: ATI Technologies Inc.
Renderer: AMD Radeon(TM) R5 340X
Version string: 3.2.13456 Core Profile Context 21.19.144.32768
Swap behavior: double buffer
Depth buffer size: 24
Stencil buffer size: 8
Shading language: 4.50
Geometry shaders supported: yes
Using deprecated functions: yes
Using point sprites: yes
Using geometry shaders: no
Context sharing enabled: yes

oywz

  • Newbie
  • *
  • Posts: 6
Re: rendering problem
« Reply #3 on: November 16, 2017, 10:39:11 AM »
This rendering bug is likely due to a nonconforming OpenGL graphics driver installed on your system. Please post the system report generated by OVITO when you chose "OpenGL information" from the Help menu.

You may be able to work around the graphics driver bug by changing some of the OpenGL-related settings in OVITO's application settings dialog (found under the 'General' tab).

Hi, Alex.
I don't know which one in OpenGL-related settings should be changed.
Do you have any suggestions?
Thanks!

Ouyang

Alexander Stukowski

  • Administrator
  • Full Member
  • *****
  • Posts: 221
Re: rendering problem
« Reply #4 on: November 16, 2017, 12:31:44 PM »
I meant the "override usage of point sprites" setting and the "override usage of geometry shaders" setting in the application settings dialog.

Here is another thing you can try: Set the rendering quality for particles to "low". This is done in the parameter panel for the "Display"/"Particles" entry in the pipeline editor:

http://ovito.org/manual/display_objects.particles.html

The final workaround I can recommend, of course, is to use the Tachyon renderer instead of the OpenGL renderer to produce image frames.