Author Topic: regarding ovito use on HPC  (Read 1254 times)

pawantr

  • Newbie
  • *
  • Posts: 1
regarding ovito use on HPC
« on: February 14, 2017, 08:43:15 AM »
hi,

 I am using OVITO on my institute's HPC cluster, i simply unzipped the tar fille and then after adding paths i started with executable "ovito" in bin. In the beginning it was working fine, but now it started showing error,"setNativeLocks failed: "Function not implemented"".
 Please suggest me possible reasons.
Thank you,


Alexander Stukowski

  • Administrator
  • Hero Member
  • *****
  • Posts: 595
Re: regarding ovito use on HPC
« Reply #1 on: February 15, 2017, 10:10:03 AM »
Hi,

I'm not sure what this error message means, I haven't encountered it before. However, I have seen a very similar type of message in the terminal: "setNativeLocks failed: Resource temporarily unavailable". It is due to a bug in an older version of the Qt library used by OVITO (https://bugreports.qt.io/browse/QTBUG-46762). It occurs every time OVITO writes to its program configuration file in the user's home directory if it is located on a network drive. In this case locking the configuration file to prevent shared access fails due to the Qt bug. However, this warning message can be safely ignored in my experience.

This being said, let me ask you:

1) Does OVITO work normally despite the message, or is it terminating right after printing that message?
2) Did you build OVITO from source, or are you using the official binaries?

Regards,
Alex