OVITO Forum

OVITO => Support Forum => Topic started by: June on December 27, 2017, 10:03:39 AM

Title: cannot construct mech in dislocation analysis
Post by: June on December 27, 2017, 10:03:39 AM
Hi, ovito users:

I want to export dislocation analysis file but at some frames this error appears: cannot construct mesh for this input dataset. Adjacent cell face not found.

How can I modify the setting to output file successfully, or can I just skip these frames?

Thank you so much.

Best wishes,
Ann
Title: Re: cannot construct mech in dislocation analysis
Post by: Alexander Stukowski on December 27, 2017, 07:09:47 PM
Dear Ann,

This is an unexpected failure of the DXA routine, which should never occur under normal circumstances. If it does occur, it probably means that the DXA routine needs to be improved in some way to correctly handle your dataset.

To this end, I am asking you to upload the input dataset (at least those simulation frame(s) for which the error occurs) or send the data file(s) directly to me. I will then try to reproduce the problem and find a fix. Please do not forget to also specify the DXA modifier settings that you used, as they may affect the occurrence of the error.

As a possible workaround, I suggest you slightly perturb the atomic positions of the input dataset. For example, you could use the Affine Transformation modifier to shift all positions by some amount before applying the DXA modifier. Maybe this helps to avoid the error, but I am not certain.

-Alexander
Title: Re: cannot construct mech in dislocation analysis
Post by: Alexander Stukowski on December 27, 2017, 07:13:01 PM
One possible explanation for this error could also be that the (periodic) simulation cell you are analysing is too small. The DXA may not be able to handle such datasets with a very short periodic length. In this case a possible workaround would be to use the "Show periodic images" modifier to replicate the crystal and increase the simulation cell size by some factor prior to applying the DXA modifier.
Title: Re: cannot construct mech in dislocation analysis
Post by: June on December 28, 2017, 02:13:26 AM
Dear Alexander,

Thank you for your reply. One frame is attached, perhaps you can figure out the problem.

Thank you for your help.

Best wishes,
Ann
Title: Re: cannot construct mech in dislocation analysis
Post by: Alexander Stukowski on January 04, 2018, 05:14:09 PM
Thanks Ann, I downloaded your test file. However, I was not able to reproduce the problem on my computer. Probably, I am using other DXA parameters than you. The easiest way to exactly reproduce your settings on my local machine would be if you save your setup as an .ovito file and give that file to me. For that, first make sure OVITO is giving you the error message. Then save the scene using the File/Save program state function in the menu. Finally, upload the .ovito state file here.

Furthermore, I noticed that your simulation is periodic only in the X-Y plane, but not along the Z direction. When loading the XYZ file, OVITO assumes by default that periodic boundary conditions are used in all three directions. This may lead to problems, because the z-coordinates of some of atoms are actually outside the simulation box in your case. Please try if turning off periodic boundary conditions along Z makes any difference. You can do that in the Simulation Cell panel (http://ovito.org/manual_testing/scene_objects.simulation_cell.html).